You need Microsoft Internet Explorer 5.5 to use EasySell Web

You can download it from http://www.microsoft.com/ie/